#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+(\.[05])?$"
Local $sString = "1" & @CRLF & _
"1.5" & @CRLF & _
"0.5" & @CRLF & _
"0" & @CRLF & _
"0.3" & @CRLF & _
"-1" & @CRLF & _
"-1.5" & @CRLF & _
"2" & @CRLF & _
"2.5" & @CRLF & _
"2.0" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")