package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+(\.[05])?$`)
var str = `1
1.5
0.5
0
0.3
-1
-1.5
2
2.5
2.0
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}