import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+(\\.[05])?$";
final String string = "1\n"
+ "1.5\n"
+ "0.5\n"
+ "0\n"
+ "0.3\n"
+ "-1\n"
+ "-1.5\n"
+ "2\n"
+ "2.5\n"
+ "2.0\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}