const regex = /(.+)(?:((?i)\sends\s[1]?[0-9]\s[ap]\.m\.))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.+)(?:((?i)\\sends\\s[1]?[0-9]\\s[ap]\\.m\\.))$', 'gm')
const str = `The Monkey Ends 9 P.M.
The Elefant Ends 12 A.M.
The Zebra Ends 2 P.M.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}