# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/&(?!(?:#\d+|#x[0-9a-f]+|\w+);)/&/gmi;t' <<< "{
ᾮ
'
&"