# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*:)(.*)(:.*)/\2/gm;t' <<< "123:12313@mail.com:hello
hello:12nj@randomwebsite.com:891"