package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*:)(.*)(:.*)`)
var str = `123:12313@mail.com:hello
hello:12nj@randomwebsite.com:891`
var substitution = "\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}