use strict;
my $str = '123:12313@mail.com:hello
hello:12nj@randomwebsite.com:891';
my $regex = qr/(.*:)(.*)(:.*)/mp;
my $subst = '\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";