re = /(.*:)(.*)(:.*)/m
str = '123:12313@mail.com:hello
hello:12nj@randomwebsite.com:891'
subst = '\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result