using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?!local).)*$";
string input = @"http://stage-plan.com
http://www.stage-plan.com
https://stage-plan.com
https://www.stage-plan.com
http://localhost/
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}