package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b0|([^\d*\.?\d*])`)
var str = `0wqeqweqwe1545513@2sa1f65.2100231wefdsfr
213123safwdas@asf.2ef3
210.850`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}