$re = '/\b0|([^\d*\.?\d*])/';
$str = '0wqeqweqwe1545513@2sa1f65.2100231wefdsfr
213123safwdas@asf.2ef3
210.850';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);