import re
regex = re.compile(r"\b0|([^\d*\.?\d*])")
test_str = ("0wqeqweqwe1545513@2sa1f65.2100231wefdsfr\n\n"
"213123safwdas@asf.2ef3\n\n"
"210.850")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")