Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
\b0|([^\d*\.?\d*])
/
g
Input 1
1
New
0wqeqweqwe1545513@2sa1f65.2100231wefdsfr 213123safwdas@asf.2ef3 210.850