// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<span[^<>]*\bclass="[^"]*(?<class>email_[^\s"]+)[^"]*">\h*(?<mail>[^\s@]+@[^\s@]+)\h*<\/span>"#).unwrap();
let string = "<span class=\" xx email_xx xx \"> test@test.test </span>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}