package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^-?(\d*\.)?\d+$`)
var str = `-4.323`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}