const regex = /0([7,8,9])([0,1])\d{8}$|234([7,8,9])([0,1])\d{8}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('0([7,8,9])([0,1])\\d{8}$|234([7,8,9])([0,1])\\d{8}$', 'gm')
const str = `08062242801
+2340862242901
6754
2340862242901
+2348062242901
2349162242901
18062242901
08062242801
08262242801
08162242801
08562242801
080622428011
09162242801
07262242801
07062242801
09262242801
07562242801
06062242801
+2344045751111`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}