# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<soap_envelope><soap:Envelope.*\/soap:Envelope>)"
test_str = " {\"severity\":\"DEBUG\",\"logger\":\"org.mule.module.http.internal.HttpMessageLogger\",\"thread\":\"[dmvproxy-1.0.2-RELEASE].HTTP_Listener_Configuration.worker.790\",\"message\":\"LISTENER\\nPOST \\/inolrsproxy HTTP\\/1.1\\r\\nContent-Type: text\\/xml; charset=UTF-8\\r\\nAccept: *\\/*\\r\\nUser-Agent: Apache CXF 3.1.4\\r\\nX-Takipi-SN: 18480\\r\\nCache-Control: no-cache\\r\\nPragma: no-cache\\r\\nHost: dmv-proxy.dmv-proxy.rancher.internal:8081\\r\\nConnection: keep-alive\\r\\nContent-Length: 3413\\r\\n\\r\\n<soap:Envelope xmlns:soap=\\\"http:\\/\\/schemas.xmlsoap.org\\/soap\\/envelope\\/\\\"><soap:Body><test>testvalue<\\/test><\\/soap:Body><\\/soap:Envelope>\"}"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.