import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|\\D)([790]\\d{1,4})(?!\\d)";
final String string = "5494398 70008 'order # 5494398 Product#: 70008\n"
+ "5001447452 ' should be ignored\n"
+ "6415366 OSW SHIP 70052 'order # 6415366 Product#: 70052\n"
+ "6567598y7058 Nov 20 'order # 6567598 Product#: 7058\n"
+ "OSW SHIP 70054 RH STRONGBACKS 'order # N/A Product#: 70054\n"
+ "OSW HS 70052 70053 'order # N/A Product#: 70008\n"
+ "6511534 04450 'order # 6511534 Product#:either 04450 or 0445 (this is only case)\n"
+ "6511538 0046 'order # 6511538 Product#: 0046\n"
+ "0046 6387125 'order # 6387125 Product#: 0046\n"
+ "OSW 70032 'order # N/A Product#: 70032\n"
+ "OSW HEX Blots 046 047 048 049 'order # N/A Product#: 064 & 047 & 048 & 049 (4 matches)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}