#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[\w]{16}.[\w]{44}$"
Local $sString = "### Do not type in the full URL (e.g. "sub.example.com/blahblah")" & @CRLF & _
"### Use the path only, starting with the first slash" & @CRLF & _
"### - Pranav Mishra" & @CRLF & _
"" & @CRLF & _
"# Generic API" & @CRLF & _
"## Regex: ^/api([/?].*)?$" & @CRLF & _
"/api?some_random_api_code_here" & @CRLF & _
"" & @CRLF & _
"# Health Check" & @CRLF & _
"## Regex: ^/healthz.*$" & @CRLF & _
"/healthz/1" & @CRLF & _
"" & @CRLF & _
"# PrivateBin test" & @CRLF & _
"## Regex: [\w]{16}#[\w]{44}$" & @CRLF & _
"/?6264cc7c26fd522b#6LgXAArG8BYwFsCnFY8QG7w65bfh3fvTAbx9T9aE3jG3" & @CRLF & _
"/?7b01a9919ac887ba#FdvmDkrcGX2F6Gvc1tq15xEaaLzMMBoPj6AZVsGPL9VP" & @CRLF & _
"/?c6e27eda79460e19#2vGuJsfKvKr1U2vAtDPHAoCJxXZ2jXj8QtX3GPovMr4M" & @CRLF & _
"/?b70ec2de34888ae8#Dz1PRy9raeFFaTCu3453gz9tqWBu1YCMkYkuUuy2f93M" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")