using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"node.*?=(\w+).*?\s(\d+)";
string substitution = @"";
string input = @"digraph A {
rankdir = LR;
node [shape=circle,style=filled] 0
node [shape=circle,style=filled] 1
node [shape=circle,style=filled] 2
node [shape=circle,style=filled] 3
node [shape=circle,style=filled] 4
node [shape=circle,style=filled] 5
node [shape=circle,style=filled] 6
node [shape=circle,style=filled] 7
node [shape=circle,style=filled] 8
node [shape=circle,style=filled] 9
node [shape=doublecircle,style=filled] 10
0 -> 4 [label=""g ""];
0 -> 1 [label=""b ""];
1 -> 2 [label=""o ""];
2 -> 7 [label=""y ""];
2 -> 3 [label=""o ""];
3 -> 7 [label=""k ""];
4 -> 5 [label=""i ""];
5 -> 6 [label=""r ""];
6 -> 7 [label=""l ""];
7 -> 9 [label=""<+N:s> ""];
7 -> 8 [label=""<+N:0> ""];
8 -> 10 [label=""<+Sg:0> ""];
9 -> 10 [label=""<+Pl:0> ""];
}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}