$re = '/^((?:[^{\n])+)({{|{:)*/m';
$str = 'abcd
abcd{{
abcd{:efg
abcd
ddddd
^((?:.)+)({{|{:)*.*$
^(?:[^{])+)$
((?:[^(?:{|$)])+)({{|{:)*.*$
(?:[^{])+({{|{:|$)*
((?:[^(?:{|$)])+)
http://stackoverflow.com/questions/40197545/javascript-regular-expression-match-anything-but
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);