import Foundation
let pattern = #"^((?:[^{\n])+)({{|{:)*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
abcd
abcd{{
abcd{:efg
abcd
ddddd
^((?:.)+)({{|{:)*.*$
^(?:[^{])+)$
((?:[^(?:{|$)])+)({{|{:)*.*$
(?:[^{])+({{|{:|$)*
((?:[^(?:{|$)])+)
http://stackoverflow.com/questions/40197545/javascript-regular-expression-match-anything-but
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)