re = /^(?<device>[^ ]+)\s+\w+\s+\w+\s+\w+\s+\w+\s+(?<disk>\d+)/m
str = '/dev/nvme4n1p1 xfs 50G 555M 50G 2% 25M 33K 25M 1% /var/www'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end