import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[^<>()[\\].,;:\\s@\"]+(\\.[^<>()[\\].,;:\\s@\"]+)*|\"[^\\n\"]+\")@(?:[^<>()[\\].,;:\\s@\"]+\\.)+[^<>()[\\]\\.,;:\\s@\"]{2,63}$";
final String string = "abcde.fghi@gmail.com\n\n"
+ "nombre-apellido@do-mi-nio.info\n"
+ "germán@bla.com\n"
+ "yo@mi-compañía.com\n"
+ "estação@brasil.com.br\n"
+ "no@esunmail\n"
+ "**@as\n"
+ "juan@{{192.168.1.52}}\n"
+ "*****@mail.xx\n"
+ "#($^%#$@^(#$^.com";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}