const regex = /(?<=[a-zA-Z]=")([\w\W]*)(?:<ins>|<del>)([\w\W\s]*)(?:<\/ins>|<\/del>)([\w\W]*)(?=">)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[a-zA-Z]=")([\\w\\W]*)(?:<ins>|<del>)([\\w\\W\\s]*)(?:<\\\/ins>|<\\\/del>)([\\w\\W]*)(?=">)', 'g')
const str = `<div class="class1<ins>class2</ins>" style=";display:block;">Some Text</div>
`;
const subst = `$1 $2 $3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);