$re = '/@\[[a-z0-9-]+\]\((\w+(?:-\w+)*)\)/m';
$str = '@[a12-3asd-32](john)
@[b12-32d1-23](martha)
@[c12-12d1-13](john-user-1)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);