package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<Profilename>\w+)[\-]?(?<Profilestep>.*)`)
var str = `Test_Profile-TestStep
Test_Profile123
Testmy-3456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}