$re = '/(?<Profilename>\w+)[\-]?(?<Profilestep>.*)/m';
$str = 'Test_Profile-TestStep
Test_Profile123
Testmy-3456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);