$re = '/\b[^p\s]\w+/m';
$str = '
I must use regex to select all words that doesn\'t start with letter "p". For example:
book, laptop, promise
So, the regex formula must select only book, laptop
My formula doesn\'t work, don\'t know why:
FIND: \\b(?!p)\\w+\\b OR \\b(?!p){1}\\w+\\b OR \\b(?![p])\\w+\\b
My formulas selects also some single letters, but not just words \\w+
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);