using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"\b(?!\d(\d)\1)[01]+\b";
        string substitution = @"-";
        string input = @"0101010, 1010101010
1
1111000";
        RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
        
        Regex regex = new Regex(pattern, options);
        string result = regex.Replace(input, substitution);
    }
}