use strict;
my $str = '0101010, 1010101010
1
1111000';
my $regex = qr/\b(?!\d(\d)\1)[01]+\b/imp;
my $subst = '-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";