package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Z]{2,}`)
var str = `lower case string
lower with UPPER case string`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}