package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`,.*,\d`)
var str = `a,b,c,123,def,ghi,jkl,mno,pqr,stu,vxw,yz`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}