#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https:\/\/www\.own3d\.tv\/en\/product\/[a-zA-Z0-9-\/]*-series-[a-zA-Z0-9-\/]*\/?$"
Local $sString = "select all english detail pages of overlay packages" & @CRLF & _
"starting with: https://www.own3d.tv/en/product/" & @CRLF & _
"containing between various characters: -series-" & @CRLF & _
"-------------------------------------------------------" & @CRLF & _
"https://www.own3d.tv/en/product/arcadepro-series-package/" & @CRLF & _
"https://www.own3d.tv/en/product/dj-series-package/" & @CRLF & _
"https://www.own3d.tv/en/" & @CRLF & _
"https://www.own3d.tv/en/product/8-pack-animated-reaper-twitch-emotes-sales-bundle/" & @CRLF & _
"https://www.own3d.tv/en/product/twitch-channel-points-ghost/" & @CRLF & _
"https://www.own3d.tv/de/produkt/nexus-series-package/" & @CRLF & _
"https://www.own3d.tv/pt-br/produto/nexus-series-package/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")