$re = '/^(3[01]|[12][0-9]|0[1-9])$/m';
$str = '01
02
03
09
10
11
15
19
20
25
30
31
32
33
100';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);