$re = '/[a-z]+=".+"/i';
$str = '<section class="fragment" id="foo">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);