const regex = /(?:(?P<inverted>\!) )?(?P<names>\-{1,2}\S+)($| (?P<values>.+(?=(?: [\!|\-])|$)))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?P<inverted>\\!) )?(?P<names>\\-{1,2}\\S+)($| (?P<values>.+(?=(?: [\\!|\\-])|$)))', 'g')
const str = `-a val1 ! -b val2 --custom "string with crazy -a --test stuff inside" --param-with-dash val1 val2 -c ! -d ! --test
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}