# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([\/#]?[A-Za-z0-9$]+)[\/_].*/\1/gm;t' <<< "#Tableau_6_sid:15251a_4i_2a
/15722c29d_PhotoImageCameraPro
JAVA/15722c29d_PhotoImageqeeee
ABC_CUST_INFO_D
BBC_CUST_ENTRY_F
FHS_PRDCT_STST_T
GHS_INVTR_CD_DRY"