#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[^0-9a-z -]+"
Local $sString = "шфшешег123asdsafsafре-реtjrt"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)