using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^0-9a-z -]+";
string substitution = @"";
string input = @"шфшешег123asdsafsafре-реtjrt";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}