use strict;
my $str = 'шфшешег123asdsafsafре-реtjrt';
my $regex = qr/[^0-9a-z -]+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";