using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(0?[1-9]|[12]\d|3[01])[\/\-.](0?[1-9]|[12]\d|3[01])[\/\-.](\d{2}|\d{4})\b";
string input = @"Bắt các chuỗi ngày tháng này
12/01/2017
15/2/2017
3/03/2018
12/24/2018
1.1.2018
7-9-18
1.31.2018
Không bắt các chuỗi như thế này, vì không đúng ngày tháng
123/2/1234 13/ab/3346 12/223/12 60/60/2018 32/12/2018
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}