#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<label .*?>(.*?)<\/label>"
Local $sString = "<label class="s-nav right" for="s-22">simply</label>" & @CRLF & _
"<label class="s-nav left" for="s-21">dummy</label>" & @CRLF & _
"<label class="s-nav right" for="s-23">text</label>" & @CRLF & _
"<label class="s-nav left" for="s-22">of the printing</label>" & @CRLF & _
"<label class="s-nav right" for="s-24">and typesetting</label>" & @CRLF & _
"<label class="s-nav left" for="s-23">industry</label>" & @CRLF & _
"<label class="s-nav right" for="s-25">Lorem Ipsum</label>" & @CRLF & _
"<label class="s-nav left" for="s-24">Ipsum</label>"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)