import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<label .*?>(.*?)<\\/label>";
final String string = "<label class=\"s-nav right\" for=\"s-22\">simply</label>\n"
+ "<label class=\"s-nav left\" for=\"s-21\">dummy</label>\n"
+ "<label class=\"s-nav right\" for=\"s-23\">text</label>\n"
+ "<label class=\"s-nav left\" for=\"s-22\">of the printing</label>\n"
+ "<label class=\"s-nav right\" for=\"s-24\">and typesetting</label>\n"
+ "<label class=\"s-nav left\" for=\"s-23\">industry</label>\n"
+ "<label class=\"s-nav right\" for=\"s-25\">Lorem Ipsum</label>\n"
+ "<label class=\"s-nav left\" for=\"s-24\">Ipsum</label>";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}