# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<label .*?>(.*?)<\/label>"
test_str = ("<label class=\"s-nav right\" for=\"s-22\">simply</label>\n"
"<label class=\"s-nav left\" for=\"s-21\">dummy</label>\n"
"<label class=\"s-nav right\" for=\"s-23\">text</label>\n"
"<label class=\"s-nav left\" for=\"s-22\">of the printing</label>\n"
"<label class=\"s-nav right\" for=\"s-24\">and typesetting</label>\n"
"<label class=\"s-nav left\" for=\"s-23\">industry</label>\n"
"<label class=\"s-nav right\" for=\"s-25\">Lorem Ipsum</label>\n"
"<label class=\"s-nav left\" for=\"s-24\">Ipsum</label>")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.