import Foundation
let pattern = #"<label .*?>(.*?)<\/label>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<label class="s-nav right" for="s-22">simply</label>
<label class="s-nav left" for="s-21">dummy</label>
<label class="s-nav right" for="s-23">text</label>
<label class="s-nav left" for="s-22">of the printing</label>
<label class="s-nav right" for="s-24">and typesetting</label>
<label class="s-nav left" for="s-23">industry</label>
<label class="s-nav right" for="s-25">Lorem Ipsum</label>
<label class="s-nav left" for="s-24">Ipsum</label>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)