$re = '/^[-+]?(\d+[,.]|\d*[.,]?\d+)(e[-+]?\d+)?$/i';
$str = '3.14159
';
$subst = "-";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;