using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w{3})(\w+)?(\w{3})";
string substitution = @"$1$3";
string input = @"Hmm. We’re having trouble finding that site.
Check that Firefox has permission to access the web (you might be connected but behind a firewall)
vamos fazer de conta que criamos um projeto de multipla escolha
codigo-cliente-no-cadastro-unico
cxp-microintegration-teste-sistema-conta
testando-abreviação-simples-com-expressões-regulares
Your account, a is not authorized to view this page. Make sure the URL is correct and your account has access.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}