# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\w{3})(\w+)?(\w{3})"
test_str = ("Hmm. We’re having trouble finding that site.\n\n"
"Check that Firefox has permission to access the web (you might be connected but behind a firewall)\n\n"
"vamos fazer de conta que criamos um projeto de multipla escolha\n\n"
"codigo-cliente-no-cadastro-unico\n"
"cxp-microintegration-teste-sistema-conta\n"
"testando-abreviação-simples-com-expressões-regulares\n\n"
"Your account, a is not authorized to view this page. Make sure the URL is correct and your account has access.")
subst = "$1$3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.